三歩あるけば物も忘れる

私メタボックル!お腹のお肉の妖精さ!

ユーザ用ツール

サイト用ツール


サイドバー

  
人気ページTOP10

156

インフラ構築:JobArrangerforZabbix:1.環境準備-サーバー-PostgresSQL

インフラ構築/JobArrangerforZabbix/1.環境準備-サーバー-PostgresSQL

・ZabbixとJobArrangerは同一サーバとします。
・JobArrangerは検証した際のバージョン(jobarranger-server-postgresql-5.0.0-1.el8.x86_64.rpm)で記載しています。

JobArrangerのインストール

JobArrangerのRPMを下記のURLよりダウンロードします

https://www.jobarranger.info/redmine/projects/job-arranger-for-zabbix/repository

#例:PostgresSQL、RHEL8、jobarranger5.0.0用の場合
#https://www.jobarranger.info/redmine/projects/job-arranger-for-zabbix/repository/22/raw/5.0.0/Job%20Arranger%20Server/jobarranger-server-postgresql-5.0.0-1.el8.x86_64.rpm

#ダウンロード
curl -OL [ダウンロードURL]

#jobarranger-server-postgesql-*.*.*-*. <各OS名> . <アーキテクチャ> .rpm 形式のファイル名で保存されます。
#jobarranger-server-postgresql-5.0.1-1.el8.x86_64.rpm

RPMコマンドでインストール

#インストール
rpm -ivh jobarranger-server-postgresql-5.0.0-1.el8.x86_64.rpm

インストール注意事項

■以下のメッセージが表示された場合
error: Failed dependencies:
   libssh2 >= 1.0.0 is needed by jobarranger-server-postgresql-5.0.1-1.el8.x86_64
   libssh2.so.1()(64bit) is needed by jobarranger-server-postgresql-5.0.1-1.el8.x86_64

下記コマンドでlibssh2をインストールした後に、jobarrangerのインストールコマンドを実行します。

#libssh2をインストール
dnf -y install libssh2

#jobarrangerのインストー
rpm -ivh jobarranger-server-postgresql-5.0.0-1.el8.x86_64.rpm

■以下のメッセージが表示された場合
error: Failed dependencies:
   libmariadb.so.3()(64bit) is needed by jobarranger-server-postgresql-5.0.1-1.el8.x86_64.rpm
   libmariadb.so.3(libmysqlclient_18)(64bit) is needed by jobarranger-server-postgresql-5.0.1-1.el8.x86_64.rpm

下記コマンドを実行します。

dnf localinstall jobarranger-server-postgresql-5.0.0-1.el8.x86_64.rpm

インフラ構築/JobArrangerforZabbix/1.環境準備-サーバー-PostgresSQL.txt · 最終更新: 2021/01/20 by admin